Nuevas vulnerabilidades en Internet Explorer y PowerPoint


Coincidencia o no, apenas unas horas después de que Microsoft publicara su parche oficial que corrige la vulnerabilidad VML, ha aparecido una nueva forma de ejecutar código arbitrario de forma inadvertida para el usuario de Internet Explorer. Por si fuera poco, simultáneamente Microsoft ha confirmado una grave vulnerabilidad en PowerPoint.





En julio de 2006, HD Moore se propuso hacer pública una vulnerabilidad
cada día que afectase a navegadores. Debido a su partición en el
proyecto Metasploit, dice poseer una amplia colección de errores, y
bautizó a ese mes como el de los bugs en navegadores. Eligió y publicó
una muestra cada uno de sus 31 días. Aunque no se centró en Internet
Explorer, sí que es cierto que la mayoría le afectaban. Muchos no eran
más que "simples" formas de hacer que el navegador mordiese el polvo
(dejase de responder o acaparase todos los recursos), pero otros
quedaron como posibles métodos de ejecución de código.

El día 17 de julio publicó un fallo relacionado con el método setSlice()
del navegador que fue calificado en un principio como denegación de
servicio. Sin embargo, el día 27 de septiembre aparece una forma de
aprovecharlo para ejecutar código. No deja de ser más que destacable la
"casualidad" de que surja un nuevo agujero de seguridad en Internet
Explorer horas después de que oficialmente se cierre otro. Hace ya meses
que Microsoft no hace más que sofocar fuegos (más o menos a tiempo,
siempre discutible) para que se prenda otra llama que permita nuevos
ataques. Parece como si los atacantes esperasen pacientemente a que se
corrija una vulnerabilidad, aprovechándola al máximo, para echar mano de
otra y volver a infectar sistemas.

También como "casualidad" (por la coincidencia en el tiempo), Microsoft
ha publicado un aviso de seguridad oficial en el que afirma que existe
una vulnerabilidad en PowerPoint (en todas sus versiones, incluso para
Mac) que permite la ejecución de código arbitrario. Este fallo se está
aprovechado activamente para la instalación de malware. Después
de algunos errores cometidos por casas antivirus, en los que se
calificaba como "0 day" vulnerabilidades con cierta solera, esta vez
parece que sí, que el peligro es real y no existe parche.

En realidad, no existe parche oficial para ninguna de estas
vulnerabilidades. Para Internet Explorer, se recomienda desactivar la
ejecución de componentes ActiveX en el navegador, si es posible usar
alternativas (cada vez más necesario) o utilizar la aplicación con
mínimos privilegios. Para PowerPoint, igualmente cabe la posibilidad de
usar alternativas (OpenOffice.org se presenta como perfecta candidata),
la edición Viewer de PowerPoint para abrir documentos no solicitados o
sospechosos o también protegerlo con mínimos privilegios. En ambos casos
siempre es necesario mantener un sistema antivirus actualizado.

En estos momentos, para Microsoft existen cuatro vulnerabilidades más
o menos recientes y que permiten ejecutar código (y además se está
haciendo). Una en Word (conocida públicamente desde el día 5 de
septiembre), dos en Internet Explorer (una desde el 13 de septiembre
y la que acabamos de describir) y otra en PowerPoint (también recién
descubierta).

Con esta tendencia, Microsoft se enfrenta a un grave problema y todavía
le queda un duro trabajo por hacer. Los usuarios finales y
administradores sufren las consecuencias, y debe ser más que complejo y
agotador el poder llevar la cuenta de las aplicaciones vulnerables, las
contramedidas efectivas y los fallos corregidos. Sin duda ellos se
llevan la peor parte.

Más información:

MoBB #18: WebViewFolderIcon setSlice
http://browserfun.blogspot.com/2006/07/mobb-18-webviewfoldericon-setslice.html

Vulnerability in PowerPoint Could Allow Remote Code Execution
http://www.microsoft.com/technet/security/advisory/925984.mspx

19/09/2006 Contramedidas prácticas para las últimas vulnerabilidades de Microsoft
http://www.hispasec.com/unaaldia/2887

Fuente
Sergio de los Santos
hispasec.com



Otras noticias de interés:

Un error en Firefox 3.0.2 acelera salida Firefox 3.0.3
Via laconsolablog.com nos enteramos que la gente de Mozilla ha liberado una nueva versión del popular navegador Firefox, esto debido a un error en el administrador de contraseñas, el cual produce que una contraseña con caracteres internacionales p...
SSL bug persiste en IE o Safari
Nueve semanas después que un hacker demostrara en la conferencia de seguridad Black Hat una vulnerabilidad que afecta al protocolo de cifrado SSL (Secure Sockets Layer), el más usado en aplicaciones de comercio electrónico, multitud de sitios y ap...
Facebook censura contenidos
Facebook no entiende de democracia y tampoco de la desesperada situación que viven millones de mujeres en el mundo islámico. ...
Políticas de privacidad de Facebook
Estemos o no acostumbrados a los continuos cambios que constantemente realiza Facebook, la verdad es que siempre son un fastidio, sobre todo en lo que respecta a la configuración continua de nuestras propias cuentas de usuario. Pues bien, Facebook u...
Chrome establece un nuevo estándar de seguridad en navegadores
Todos los fabricantes de navegadores deberían echar un vistazo a Google Chrome y aislar los datos no fiables del resto del sistema operativo, según destaca un investigador de seguridad....
Los coches modernos son vulnerables a ataques maliciosos
La idea de que unos hackers entren en tu PC es suficientemente preocupante. ¿Qué pasaría si pudiesen tomar control del sistema que controla tu coche mientras estás conduciendo? La amenaza es real y unos investigadores en seguridad lo han comproba...
MS y Yahoo! anuncian colaboración entre sus mensajeros
Con el auge de la mensajería en el mercado corporativo, las empresas comienzan a firmar los primeros acuerdos de interoperabilidad con el fin de ofrecer un mejor servicio a sus clientes. En este contexto, Microsoft y el portal de c...
Linus aclara la situación sobre el scheduler (planificador)
El planificador SD y el CFS se han disputado recientemente el gobierno del futuro núcleo Linux, y al final Linus Torvalds decidió que CFS sería el que se incluiría a partir 2.6.23. Las razones del porqué, a continuación....
Apple soluciona ocho problemas de seguridad en QuickTime
Apple ha publicado una nueva versión de QuickTime (la 7.6), que solventa siete problemas de seguridad en sus versiones para Windows y OS X (Leopard y Tiger). Además se ha publicado un boletín de seguridad adicional para solucionar un fallo en el c...
Radware advierte ataques DDoS
Las acciones de los hacktivist, los hackers que buscan cambios sociales o económicos, podrían incrementarse en un futuro cercano. Una investigación sobre los ataques DDoS realizados por hacktivist en los últimos meses ha llevado a Radware a avisa...

Brindanos
un o una


Redes Sociales

Publicidad


Gana Bitcoins desde tu casa

Categorías


Planeta Vaslibre

Blog Roll




Nube de tags

  • anonimato
  • anonimo
  • antivirus
  • apache
  • blog
  • bsd
  • bug
  • centos
  • chrome
  • cifrado
  • computer
  • debian
  • exploits
  • explorer
  • fedora
  • fice
  • firefox
  • forense
  • freebsd
  • gentoo
  • github
  • gnome
  • gnu
  • gpl
  • gtk
  • hack
  • hacking
  • hosting
  • informatica
  • internet
  • isos
  • libre
  • licencias
  • linux
  • linuxmint
  • lxde
  • micros
  • mint
  • mit
  • mozilla
  • mysql
  • noticia
  • nuevas
  • opensource
  • pgp
  • php
  • powerpoint
  • sabayon
  • seguridad
  • system
  • tecnologia
  • thunar
  • thunderbird
  • tor
  • troyanos
  • tware
  • ubuntu
  • underground
  • vaslibre
  • virus
  • viserproject
  • vivaldi
  • vulnerabilidades
  • web
  • website
  • windows
  • xanadu
  • xfce
  • xombra